Windows Vista Neuinstallation auf Dell Studio 15!(AHCI Problem)

Bei den Notebooks der Dell Studio Serie wird der AHCI (Advanced Host Controller Interface) Modus unterstützt und ist Standardmäßig auch im BIOS aktiviert.

Auszug aus Wikipedia:

So muss für Mainboards, deren Controller AHCI unterstützt, kein spezieller Serial-ATA-Treiber mehr entwickelt werden. Stattdessen wird für eine vollständige Unterstützung von Geräten wie z. B. Festplatten lediglich ein zur Verfügung stehender, einheitlicher AHCI-Treiber benötigt.

Wer die Vorinstallation von Windows Vista auf seinem Dell Studio Notebook benutzt brauch sich zunächst nicht mit dem AHCI Modus zu beschäftigen.
Wer jedoch eine Neuinstalltion von Vista machen möchte, der wird am Anfang der Installtion eine Fehlermeldung kriegen, dass nicht alle Treiber Gerätetreiber gefunden werden konnten. Das liegt daran, dass bei Windows Vista der AHCI Modus für gewöhnlich deaktiviert ist.
Um die Installation trotzdem durchführen zu können, muss man zunächst den AHCI Modus im BIOS unter den SATA Einstellungen deaktivieren (In das BIOS gelangt man, wenn man beim Booten F12 gedrückt hällt bis sich ein Blau hinterlegter Bildschirm öffnet). Wenn Sie den AHCI Modus deaktiviert haben, können Sie die Änderungen speichern und das BIOS verlassen. Der Rechner sollte selbstständig rebooten.

Nun dürfte die Installation eines alternativen Betriebssytems funktionieren.

Möchten Sie den AHCI Modus unter Vista jedoch unbedingt nutzen, so aktivieren Sie diese einfach (wie unten beschrieben) in Windows und aktivieren daraufhin den AHCI Modus wieder im BIOS.

AHCI Modus unter Windows Vista aktivieren:
Quelle: Klick

1. Beenden Sie alle Windows-basierten Programme.
2. Klicken Sie auf Start, geben Sie regedit im Feld Suche starten ein, und drücken Sie anschließend die [EINGABETASTE].
3. Wenn das Dialogfeld Benutzerkontensteuerung eingeblendet wird, klicken Sie auf Fortsetzen.
4. Klicken Sie auf den folgenden Unterschlüssel in der Registrierung:

HKEY_LOCAL_MACHINESystemCurrentControlSetServicesMsahci
5. Klicken Sie im rechten Fensterbereich in der Spalte Name mit der rechten Maustaste auf Start, und klicken Sie anschließend auf Ändern.
6. Geben Sie im Feld Wert den Wert 0 ein, und klicken Sie anschließend auf OK.
7. Klicken Sie im Menü Datei auf Beenden, um den Registrierungseditor zu beenden.

Achtung:
Sollten Sie den Registrierungseditor unsachgemäß benutzen, kann dies dazu führen, dass das Betriebssystem dadurch nicht mehr funktionsfähig ist und Sie ihre Daten verlieren. In diesem Fall übernehme ich keine Kosten oder ähnliches. Die Durchführung dieser Anleitung ist also auf eigener Gefahr!

Ähnliche Artikel:

20 Gedanken zu „Windows Vista Neuinstallation auf Dell Studio 15!(AHCI Problem)

  1. habe ich einen denkfehler?
    müsste es nicht eigentlich im letzten satz des absatzes unter dem wiki-zitat heißen „Das liegt daran, dass bei Windows Vista der AHCI Modus für gewöhnlich AKTIVIERT ist.“

    ansonsten habe ich noch eine frage: was hat man für nachteile, wenn man den ahci modus nach einer windows-neuinstalltion nicht wieder aktiviert? gibt es da welche?
    und man muss diesen modus auch über diesen „komplzierten“ weg wieder einschalten, also einfach im bios auf aktivieren umstellen funktioniert nicht?

  2. Ja ich denke du hast einen DENKFehler 😉

    Der AHCI Kompatiblitätsmodus ist in Vista deaktiviert, somit unterstützt dieser keinen vom BIOS eingeschalteten AHCI Modus und muss somit zunächst in Vista aktiviert werden, bevor es im BIOS aktiviert wird und somit auch läuft!

    Ja du musst diesen „komplizierten“ weg gehen. Wenn du Ihn nur im BIOS wieder einschaltest, wirst du bei jedem boot nen bluescreen bekommen, da vista damit nicht klar kommt!

    Der AHCI Modus wird dir einen leichten Performance Schub geben, wenn du mehrere Verschiedene Festplattenzugriffe gleichzeitig hast. Außerdem funktionieren ohne Ihn einige Stromsparfunktionen nicht. Also, es lohnt sich schon diese 5 Minütige Prozedur aufzunehmen, da es ja eh nen Moment dauert, bis Vista installiert ist 😉

  3. Hab mal nachgeschaut! Du brauchst nen Floppy (Diskettenlaufwerk) und nen extra treiber für ahci. Ist ziemlich umständlich das zu installieren, drum würde ich dir raten, einfach nur den ahci modus abzuschalten und es so zu lassen. Wichtige oder großartig tolle Vorteile hat AHCI nun auch nicht 😉

  4. ja denke auch dass ichs beim ahci belassen sollte, performance sollte reichen (falls mein studio auch tatsächlich geliefert wird) .Das Xp Treiberpaket für DellStudio dass du kürzlich hochgeladen hast muss ich aber trotzdem installieren?

  5. Hey Martin,
    wie schalte ich denn das AHCI in Vista ab? Mein Problem ist folgendes:
    Ich habe AHCI im Bios abgeschaltet, dann xp installiert mit den entsprechenden Studio 15 Treibern, nun will ich aber Vista parallel nutzen, habe aber keinen Bootmanager (kann ich den nachträglich installieren). XP springt ohne Probleme an, aber eben natürlich nur im SATA modus. Ich habe jetzt mit der Vista Rettungs Umgebung mein Vista zum laufen gebracht und damit aber XP aus der Boot-Reihenfolge rausgeschmissen (und Vista läuft natürlich auch nur wenn ich im Bios AHCI aktiviere)
    wie kann ich denn jetzt unter Vista das AHCI deaktivieren und einen BootManager installieren der mir XP und Vista anzeigt?
    Viele Grüße
    niklas

  6. Hi Leute,
    super Blog btw!

    Bei mir gibt es den DWORD Msahci nicht. habe ihn testweise mal angelegt und neugestartet. Leider ohne Erfolg. Ich habe den IaStor.sys ins drivers verzeichnis in system32 kopiert und auch die INFs per rechtsklick installiert. Außerdem habe ich schon mit „künstlicher“ Erzeugung der Registryeinträge für den Treiber geforscht. Bringt bei mir leider nichts. Irgendwas ist an meinem Ansatz falsch 🙂

    Nebenbei bemerkt: ich spreche von diesem Matrix Storage Manager. Davon die INF/sys files. Die sind doch die richtigen für den Chipsatz des 1537? Habe ein GM45 Express Set…..

    Danke für Eure Hilfe

  7. Den Eintrag sollte es geben, wenn du wirklich in HKEY_LOCAL_MACHINE warst.
    Ob das die richtigen für den Matrix Storage Manager sind, kann ich dir nicht sagen, da ich das Studio nicht mehr besitze und somit nicht mehr nachgucken kann. Und ob er für das 1537 passt ist die nächste Frage, ich hatte ja damals nach 1535 geforscht….

  8. Also bei mir funktioniert das leider nicht!!
    Das ich den ordner net in der regedit habe!
    gibts keine andere möglichkeit den ahci treiber nachträglich beim studio 15 zuinstallieren (unter XP)

  9. Hi Andreas,
    bei mir sieht es exakt gleich aus. Die Einträge in der Regsitry hab ich nicht und von Hand hinzufügen bewirkt gar nichts (logischerweise). Weiterhin Bluescreen…. Die Matrix Treiber lassen sich jedoch scheinbar installieren. kann sie z.b. über die vorhandnen Intel(R) ICH9M/M-E 2 port Serial ATA Storiage Controller 1 oder 2 im gerätemanager drüberinstallieren.

  10. Pingback: Sonstige Windows Vista Neuinstallation Fehler

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.