Xampp 1.6.7 unter Vista mit blockierten Ports!

Vorgeschichte:
Wenn man mit seinem Laptop eh nicht zu 100% zufrieden ist und man selbst schon fast von einem Fehlkauf spricht, kommt es einem gerade recht, wenn wichtige Programme wie xampp zusätzlich ihren Dienst nicht ausführen! Da ich gerade an 2 Projekten arbeite, für die ich ein einen PHP Interpreter benötige, war ich schon fast gezwungen alle zu interpretierenden Dateien nach jeder kleinen Änderung auf meinem Webspace hochzuladen um dort zu überprüfen ob der gewünschte Effekt entsteht und daraufhin festzustellen, dass ich eine Kleinigkeit im Code vergessen hab und somit die Tortur von neuem startet!

Fehlersuche und Fehlerbeseitigung:
Nach der Installation des Tools ließ sich lediglich der MySQL Dienst starten. Der Apache machte rein nach einem klick auf Start rein garnichts. Es gab auch keine Ausgabe einer Fehlermeldung!
Aus diesem Grund habe ich mich zunächst dazu entschlossen den Batchdatei per Hand zu starten. Dies hat natürlich ebenso wenig geklappt, jedoch habe ich diesmal wenigstens eine Fehlermeldung nach dem MicrosoftMotto:

„Sie verfügen nicht über ausreichende Berechtigungen diese Aktion durchzufüren“

Für mich lag die Sache sofort auf der Hand! Vista mit seiner Benutzerkontensteuerung (auch UAC genannt) blockiert mir den Dienst! Also deaktivierte ich schnell die Benutzerkontensteuerung im Reiter „Benutzerkonten“ unter Systemsteuerung. Natürlich werde ich jetzt 5 mal am Tag von Vista gewarnt, dass ich die Benutzerkontensteuerung nicht mehr aktiviert habe und dies wohl hätte unabsichtlich geschehen können.
Nach einem Neustart des Systems versuchte ich nun den Dienst zu starten. Natürlich passierte nichts….
Also das gleiche nochmal: Batchdatei von Hand starten und auf Fehlermeldung warten…

Diesmal bekam ich sogar eine Fehlermeldungsnummer: 10013. Unter der Fehlernummer verriet mir der Text, dass der Port 80 bereits von einem anderen Dienst benutzt und somit blockiert wird.
Daraufhin habe ich mir das Programm TCPView runtergeladen um zu überprüfen welches Programm denn nun den Port 80 benutzt. Mir wäre spontan nur der Microsoft IIS eingefallen, der unter den Diensten jedoch nicht auftaucht.

Das Programm TCPView hat mir dann schließlich auch nicht weitergeholfen, da er mir keine Dienste für den Port 80 genannt hat.
Nachdem ich nun die Vista Systemsteuerung auswendig kenne, ist mir ein Punkt in dem Reiter „Programme und Software“ (oder wie das Symbol nun heißt) aufgefallen, über welchen sich zusätzliche Internetinformationsdienste nachinstallieren oder entfernen lassen. Also habe ich gleich mal raufgeklickt und nicht schlecht gestaunt, als ich dort in einem Unterpunkt den Microsoft IIS neben anderen HTTP Dienten gefunden habe. Diese wurden jedoch nicht unter den aktiven Diensten in der Computerverwaltung angezeigt.

Nach dem deaktivieren dieser Dienste wurde es nun jedoch auch nicht besser und ich war kurz vorm verzweifeln! Nach einiger Recherche im Internet bin ich dann darauf aufmerksam geworden, dass Skype die Ports 80 und 443 zusätzlich zu einem 7000er Port benutzt. Die Benutzung der Ports ließ sich jedoch Problemlos in den Einstellungen deaktivieren.

Nachdem ich xampp bei den Ausnahmen in der Microsoft Firewall eingetragen habe, lief alles nun wie am Schnürchen und ich bin froh, dass ich das hinter mir habe….

Fazit:
VISTA: Virus Included Switch To Apple!

Ähnliche Artikel:

3 Gedanken zu „Xampp 1.6.7 unter Vista mit blockierten Ports!

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.